LearningExpress Library

There is a new version of LearningExpress Library available, called LearningExpress Library 3.0. It features an improved look and layout, and new courses that are not available in the old version of LearningExpress Library (version 2.0), including GED 2014 courses.

Here are some important things to know:

  • If you had an account in LearningExpress Library 2.0, your username and password will not work in version 3.0. You will need to create a username and password in version 3.0.
  • If you have started a course or test in Version 2.0, you will need to finish it in Version 2.0. Your work in version 2.0 will not transfer to version 3.0.
  • Please finish all work in your version 2.0 account by June 30, 2014. After that, version 2.0 will no longer be available, and only the new version (3.0) will be available.

If you have questions, please contact staff at your library.

Access LearningExpress version 2.0 (old version)

Access LearningExpress version 3.0 (new version)